Graph not working

Hi All,

Im trying to get a basic graph from the date im getting from my broker, as its my first time I did som test and can get it working with dumy data, with my real data it seems not to want to plot the graph. The data is updated every 2 sec and I filtered it like this post explains. For some reason it wont let me plot the graph. I did the test to se if I pass it back via the broker if i cold plot then but that did not work.

Im sorry but i can not upload any files to the form, i do have the json export.

Hope you can help @Tizian.Cedalo

Hi luuk,

Let me try to help. I bumped your trust level. Try again, if you can upload the file.
Until then here some tips :slight_smile: :

Cheers,

Tizian

hey many tnx! heer is the json hope you can se what im missing.

Luuk_play.json (134.4 KB)

Luuk_play (1).json (154.4 KB)

I´m not sure, what the problem of your one created chart was. I created two myself and exported them again. They work for me :slight_smile:

Let me know if you run into more trouble.

FYI: I created simulated data, you can delete that part again, if you like. Also changed your consumer, to get the data.

One more thing:
check this out: https://docs.cedalo.com/tutorials/uielements.html#charts

I think this may help for further charting! :slight_smile:

Hey,

and jat again tnx for the fast responce! so i did the test and indeed the graph works with your data… im starting to thing its a cel formating problem with my nummbers? can that mess with a graph? did try and change the cel format to nummeric but that did not help. I cut the data from a cel in my Streamscheets and past in your respons and the graph did not show…

cheers Luuk

Hi Tizian,

I copy the numbers of a working and non working cell in Studio code. Dont know whats happening but thot I shar the code heer.

Non working number

{“o-selection”:{“id”:“88888688620”,“cut”:“0”,“range”:“C8”,“sheetid”:“2027”,“o-defaultcell”:{“o-cell”:{}},“o-columns”:{“a-column”:[{“index”:“4”,“size”:“1656”,“visible”:“1”}]},“o-rows”:{},“o-cells”:{“a-cell”:[{“c”:“4”,“r”:“7”,“o-cell”:{“o-value”:{“v”:“483.3”,“t”:“s”},“o-t”:{“o-numberformat”:{“v”:“0”,“t”:“s”},“o-localculture”:{“v”:“number%3B0%3Bfalse”,“t”:“s”}}}}]}}}

Working number

{“o-selection”:{“id”:“539552856659”,“cut”:“0”,“range”:“C9”,“sheetid”:“2027”,“o-defaultcell”:{“o-cell”:{}},“o-columns”:{“a-column”:[{“index”:“4”,“size”:“1656”,“visible”:“1”}]},“o-rows”:{},“o-cells”:{“a-cell”:[{“c”:“4”,“r”:“8”,“o-cell”:{“o-value”:{“v”:“483.300000000000011”}}}]}}}

For the experiment i typed 483 by hand in the cell and pastid the content from a non working cel. It seems that the numbers im getting from my broker ar formatted in a different way and I can not change the setting, paid with the formatting tools in the tool bar with no effect.

Cheers Luuk

Ahh thats the problem. :grinning: Easy-peasy:

If they are string formatted, that means Streamsheets things they are text.
You can change this, by adding another formular: VALUE()

Add somthing like Value(C8)
in a cell and you will have “real” numbers to work with.

1 Like

thats the fix! tnx for the fast help im starting to understand how it works!

Of Topic but how old is Streamsheets seems new? like the way the system makes it fast and fun for a non coder to start making stuf work! I can see my team to play with this :smiley:

1 Like

Awesome, thats what we want to hear :slight_smile:

The company exists about 3 years now. So pretty new is correct :metal:

If you have anymore questions let me know!