Installation issues on RaspberryPi

Hi There,
Great package, had installed on my Laptop to try out, very good, but now want it on a Dedicated Raspberry Pi server.

First of all, the instructions do not indicate what version of Raspbian 32bits or 64 bits , so I tried both.

Installed using the script and curl, It ran ok, but I notice the version is only 2.3.0, As I need the Toit Connector, so I need 2.5.0 …

64Bit: (from here:Install streamsheets on Raspberry Pi using the Snap Store | Snapcraft )
Installed the 64bit OS, tried the curl script, but that returned this error on run …

sudo ./ 
Creating network "cedalo-platform" with driver "bridge"
Pulling mosquitto (eclipse-mosquitto:2-openssl)...
2-openssl: Pulling from library/eclipse-mosquitto
be307f383ecc: Pull complete
61ce69927157: Pull complete
f4ad8db9b24c: Pull complete
Digest: sha256:9eb5ee718b7cd0f73315837d15f521c6c5b428598bc3224eeb452980f43f6241
Status: Downloaded newer image for eclipse-mosquitto:2-openssl
Pulling management-center (cedalo/management-center:2)...
2: Pulling from cedalo/management-center
ERROR: no matching manifest for linux/arm64/v8 in the manifest list entries

I then tried the Snap package, That installed and ran … but had a weird error.

If I try to put the =READ() function into a cell, it stated that the READ function is not supported, even though as you type it, you get the correct tool-tip popup for the function.

I am stumped… any and all help appreciated…

For the 64 bit version, here is a screen shot of the READ() function error

By the way, this streamsheet is an import from the working one I had on my laptop, and exported.
Both the application streamsheet and the Toit stream I was using, came across ok …

Hi bmentink,

You are absolutely right.
Up to today, there was no current 2.5 image for the Raspberry Pi available.
I have added the 2.5 image to our docker repository.

You can use the update script next to the start script to update your current image. :slight_smile:
The snap image will be updated soon.
I further will add a comment to the installation, that we currently only support arm32/v7. Thank you for mentioning! :slight_smile:

After your update, reimport your app again and let me know if you still encounter problems.

Out of interest: What kind of use case are you using Streamsheets for? Any feedback is always welcome!

Have good start in the new year


Hi Tizian,
Many thanks for the prompt reply and fix … works great :smiley:

I am using Streamsheets to monitor and control a small Aeroponics unit via an ESP32 microcontroller running the Toit language (hence my need for Toit pub/sub support)

(I could of used MQTT but wanted to try PubSub as it resides on their cloud …)

In all very impressed with Streamsheets … great job!

By the way, any long term goal’s of doing a build for FreeNAS/TrueNAS? Would be great if I could run it on my Server in a Jail instead of having to dedicate another Raspberry Pi to the job :thinking:
(Even a build for FreeBSD would be fine … )

You have a great New Year too …


Hi @bmentink,

Is there a chance for you to get Docker running on the FreeNAS?


@bmentink The snap package is now fixed, thanks for your report.



Wow, thanks for the prompt replies.

@iotrainmaker Yes, there is Docker for FreeNAS, it Installs an OS called RancherOS in a VM.
Which Docker image/command should I try with it? … the machine is AMD64

@roger.light Great, that was fast!! Many thanks, will try it out …

@bmentink : Streamsheets is not only as snap but also as docker image available. As far as I understand your system (17. Virtual Machines — FreeNAS®11.3-U2 User Guide Table of Contents) you can install ubuntu in a VM. In Ubuntu you install then docker. from there on, you can use our installer Installation | Cedalo Platform.

if this is not working for you, let me know.

Yep, know about that. What I was hoping for was Streamsheets being available in a “Plugin” for FreeNAS, so you did not have the hassle of setting up a VM and all the extra resource it takes on the server … it could still be Docker based, but run in a FreeNAS (FreeBSD) Jail instead of a VM.


In the meantime, I have installed a Ubuntu server image in a VM, then installed Docker & Docker-Compose from the repo. Then installed streamsheets as per the Linux instructions…

It all worked great, but as I mentioned at the cost of using quite a few resources of my server…

ok, to proceed:

  • what version of Rancher OS do you have?
  • what version of freeNAS are you running?

Sorry for the late reply, spent a couple of days in Hospital.

In answer to your question, the Freenas version I am currently using is FreeNAS-11.3-U5, not sure on the RancherOS version, as I have no RancherOS VM’s

Even though a RancherOS VM solution is much better than a standard VM, I still think a better solution would be to run Docker in a FreeNAS Jail (FreeBSD OS), if that was possible.


@bmentink: sorry to hear that. I hope you are feeling better now.
Concerning your system: this already helps. there where several changes in FreeNAS and also Rancher therefore I just wanted to make sure what system we are talking about before further digging. Let me discuss here internally, what we can do there.

You are using that for private purposes from what I read above, right? Or is this related to business?

Yes, private purposes “for now”. Intention is to incorporate Toit into my business once I have evaluated it on a private project.

@bmentink: ok, let us know if you have remarks on the Toit-Streamsheets combination. We are closely working with the Toit guys together and any kind of feedback is there highly welcome!