Connection-timeout to my broker on 14-day Pro Mosquitto Trial

Dear Mosquitto-users,

As my first PUBLISH-attempt to my trialbroker didn’t succeed because of a connect ETIMEDOUT, I wondered if someone already encountered the same problem with the trial? The timeout throws up indepent of the client-tool I use & the network from where I’m connecting.

In MQTT-explorer, swichting on/off ‘validate crt’, as well as specifically configuring the server crt didn’t help

In my paho-lib python-script, I got the following error:

File “C:\Users\detaeyst_admin\Miniconda3\envs\MQTT_env\lib\site-packages\paho\mqtt\”, line 3685, in _create_socket_connection return socket.create_connection(addr, timeout=self._connect_timeout, source_address=source) File “C:\Users\detaeyst_admin\Miniconda3\envs\MQTT_env\lib\”, line 808, in create_connection raise err File “C:\Users\detaeyst_admin\Miniconda3\envs\MQTT_env\lib\”, line 796, in create_connection sock.connect(sa) socket.timeout: timed out

Thx in advance for your answer!

Hello swdt,

The server cert would have been my first guess, since there is a bug in the mqtt explorer not working with “Let´s encrypt” certs.

I have had a quick look on your trial instance and tried connecting myself, and it worked for me.
I switched off the “validate certificate” and did not upload a “.crt”.

I´m not sure, what I did differently, because I this is a scenario you already tested. Can you please check again? Maybe on a different computer? We need to find out, what is different from you to me.

I will also check your logs and see if there is something I can find out from those.
Let me know if you get it going. If not, we got to dive deeper :slight_smile:

Tizian - Cedalo