MQTT on Ubuntu VM can't connect to Node-Red

I’m attempting to create Mosquitto MQTT Broker on Ubuntu. When i use sever localhost or ip, i can connect, but with ip is not. This is my firtst time i create broker and i dont know how to fix it!

Hi ducle27,

From the top of my head I can see two reasons why this could happen:
Which version do you have installed?
Starting v2 we are only allowing localhost/ by default. Add the following entry to your config file:

listener 1883

This allows further access.

Other possibility could be, that your firewall does not allow the connection. Check your fw settings to be sure :slight_smile:

Let me know if that helped :slight_smile:

Like Tizian said, on version 2.0 the broker will only listen on the local computer by default. You can configure a listener which can accept connections from remote computers and have to configure some sort of authentication at the same time. That could be password files, an authentication plugin, or not having any authentication at all. There is some documentation on the different authentication options available here: Authentication methods | Eclipse Mosquitto

I hope that helps,