Network traffic to Management Center

I’m installing Mosquitto, Streamsheets and the Management Center through Docker. Everything works perfectly, however when I am connected to the Management Center I receive traffic on the network port, something around 14 Mbps continuously.
This traffic is considered normal for communication between the Management Center and my browser or am I wrong in some configuration.
If there are more clients connected to Mosquitto generating topics, will this traffic increase?

Hi @pedro.rc ,

Thanks for your message. Just talked to the technical colleagues: 14 Mbit would be very large as traffic in this case. Since we just entered the week-end here in Germany, it might take until Monday that we will come back to you, but I guess that this traffic has other reasons than the management center.


Hi Pedro,

Sorry for the delay getting you a proper reply. The management center (MMC) backend subscribes to the # topic on Mosquitto so that it can present a topic tree of known topics to the users browsing the MMC front end. This means that traffic on the Mosquitto instance will be duplicated to the MMC. The MMC backend also has to send data to each MMC frontend that is currently open. So if you are currently sending around 14Mbps to the broker then yes, this is an expected level of traffic. We are aware that the current implementation isn’t optimised for performance and are looking into how we can optimise this and still get the same functionality.

If the bandwidth you are sending to the broker isn’t around 14Mbps then there may be another problem we need to look into.



Hi @roger.light, thanks for replying,
I’m also using MQTT Explorer trying to understand the situation, and I noticed that the amount of updates of topics $SYS is much lower than when compared to those that are updated in the TOPIC TREE of the MMC.
I think the topics update should be the same, considering that the subscribe in $SYS is the same for both.
In this sense, every update in TOPIC TREE generates the high traffic reported.
In another test I disabled all clients, leaving only the cedalo client, and there was only 1 active connection in the broker. Even in this situation, I still have that traffic.