Request SSL Ignore

I am trying to do a Read.Request function to a source that has certificate issues beyond my control.
It returns message similar to “Hostname/IP does not match certificate’s altnames: Host: XXXX. is not in the cert’s altnames: DNS:YYYY” (names changed).

How would I tackle this. Typically in node one would options like rejectUnauthorized:false or strictSSL:false in the options. I have tried adding these as headers, but they should be options, so having no success.

Please advise how to get around this.

Thank you in advance

You can make use of the generic REQUEST function. Have a look at Support for REST REQUEST via Proxy for a detailed explanation.
In your case something like
with A5 as =REQUEST(|REST_CLIENT,A1:B3,INBOX()) should do the trick.
|REST_CLIENT is a Rest Client Producer.

Let me know if you have any further questions.

Thanks for the response. This has unfortunately not resolved the issue.
When using the same request options in NodeJS natively it works as expected, namely ignoring the cert issue.

Is there a way that I can see the request being sent out in a debug somehow ?

I just realized that I had a small mistake in my example.

You could inspect the logs of the stream-service to check for any errors (but they should all be returned to the sheet anyway).

Hi Andreas,

I did use it correctly as per your corrected example without any joy. Still getting original message of the cert as per my first post.

I’m trying to debug the json object as you send it to the request object rather than the return error which is the “Hostname/IP does not match certificate’s altnames: Host: XXXX. is not in the cert’s altnames: DNS:YYYY” message.

As mentioned if I make such request in my own NodeJS example it works fine. It almost seems as if the strictSSL and/or rejectUnauthorized options are not going through

Could you try the following example REQUEST Example.json (14.4 KB)

When you do a step, you should get two messages in the inbox. One with the Hostname/IP error and one successful response.

Hi Andreas,

I have done as requested (output below of 2 messages). Both give the same result. I have also tried accessing from 3 different networks …with same result. Since the nodeJS environment is contained in the docker container my environment should not be affecting it.


I will add second image in next reply as sytem stops me adding 2 images as new forum user


Sceond image…


Hi Alfred,

I’m not quite sure what causes this.
I’ll have to investigate and get back to you when I know more.
Could you tell me what OS you are using?

Thank you for your patience.


I am on MacOS Mojave 10.14.5