Can't Read and Write Files

i would like to read a File from my directory and write the processed data to another directory.
But I have two Problems

First Problem:
I found your answer of how to read a file here: Send Text-Data to Sheet
But I can’t create a File_Consumer :frowning:
For my testing purpose I use Streamsheet on windows. Is there any issue with File_Consumer?
I can only create a Consumer for: MongoDB, Rest, MQTT and Kafka

Second Problem:
When I try to write Data to the directory, nothing happens.
And after I run some steps, I can’t edit the Function. When I try to edit, the page get’s completly white. So I have to delete and recreate the Function.

What am I doing wrong?

I have configured the producer and the function as follows:


Hi cschmitt,

Good question! :slight_smile:
We are undergoing some structural changes. Since we have made some parts of Streamsheets open source and free to use, some will remain not freely accessible.
We are still in the process of the whats and hows, but right now your first problem is due to these changes. The consuming of local data is right now not part of the open source release.
Other user still have access to it, because it is still part of the Raspberry Pi release (which is v1.3) .
This will also change with the next Pi release. :confused:

The second problem is very likely due to a wrong mount of the File Provider.
In your .YML you can change the mount in the “streamsheets-service-streams” section:

  - /tmp/examples/filefeeder:/filefeeder

This is the standard path. I personally use windows, so I changed it to this path:

  - C:\filefeeder:/filefeeder

Further, the root directory has to be equal to the entry in the yml:


The bold part is the part, which has to be referenced in the Connector.

Like this I was able to produce some test data:

I totally see, that this is not perfectly obvious, but we are in the process of uploading more and more tutorials and improve our documentation. Sorry for the inconvenience.



Hi Tizian,
thanks for your answer.

I will try the File-Writer in the next days with the windows path in the File Provider.

It’s sad, that the File Consumer isn’t part of the freely accessible version. But of course it’s okay :smiley:

Is there any possibility of getting a one or two months test version of the full-version?
Currently I’m testing streamsheet for eventually using it commercially.
And, a basic question, where can I find the prices for the commercial version?


I will write you a personal message! :slight_smile:

Hey Tizian, I ran into this same issue with the file provider, and I assume like you said the .yml is where I would be able to fix the root directory so that it can match my root directory. However, running Streamsheets over Docker on Windows 10 I do not know where my .yml file is. Where would that be for me? It’s not in my installation directory.

Hi werty,

We have changed from a multi container image to a one container image in the open source edition. This is a more straight forward setup and does not require a docker-compose file (.yml). This is why you can not find the file anymore.

The premium version still works with the .yml file for configurations.
I will check if there is a way to still manipulate the mount path with docker commands. :construction_worker_man: