Connecting to a Mongo Atlas Replica Set

Hello team,

I want to store MQTT messages to a Mongo Atlas Database. The MQTT Connector and Provider works well, the problem comes when I try to connect to my Replica Set.

I work on a Windows 10 Home, and I have the streamsheets installed in a Ubuntu 20.04. I downloaded the MongoDB container, I have tried to configure the connector but always shows me this error:

“no primary found in replicaset or invalid replica set name”.

I tried different versions of the connecting string (mongo URI) but none of them seems to work.
If I open the MongoDB container (CLI) and paste the connecting string, it connects and I’m able to store and read data to my collection from the CLI, but when I try it from the Streamsheets it doesn’t seems to work.

I also tried to connect to Mongo Atlas through Mongo CLI and then generate a connector with the host name of the container and without the connecting string in the “Replica set” field. Doing that it doesn’t shows me any error, but the data is not stored in my Mongo Atlas database either…

I paste a screenshot of my config.

Any help would be appreciated, thank you in advance :slight_smile:

Hi dvrever,

thank you for your post!
At this moment the MongoDB Connector does not support the Mongo Atlas DB.

Adding the Atlas Connection was not on our mind so far.
I just added this to our backlog. :slight_smile:

Is there a way for you to use MongoDB for now?