Management Center: Blank screen after login


I set everything up through docker compose and I get to the login screen but after that there is just a blank screen.

Docker log from Management Center:

I already tried different images (2.2.3, dev etc.) but they don’t work, too.
Javascript in browser is also active.

What am I missing here?

Sorry to hear you’re having problems!

The license check shouldn’t be a cause of any problem, and the rest of the log looks like everything is starting, so it’s difficult to say right away.

Could you share some details of your setup so I can try and reproduce this? i.e. are you on Windows/Linux/something else, what did you use to get running and anything else you think might be relevant.

Just to check - you’ve not got any script blocking plugins running in your browser?



I am running this on a Ubuntu 20.04 server and just followed the installation guide from Installation | Cedalo Platform

The only thing i changed so far was to change the installer image path from ~/cedalo_platform to a static path in the home directory.

This the output when starting though

I’ve just tried to reproduce this in a fresh digital ocean droplet running Ubuntu 20.04. This is what I did:

apt install docker-compose # install docker and docker-compose
useradd igb-mqtt # add the same user as you
mkdir /home/igb-mqtt
chown igb-mqtt /home/igb-mqtt
usermod -a -G sudo igb-mqtt # make sure they can sudo
passwd igb-mqtt
su - igb-mqtt # switch to the user
sudo docker run -it -v /home/igb-mqtt/cedalo_platform:/cedalo cedalo/installer:2-linux # run the installer as sudo
cd /home/igb-mqtt/cedalo_platform
sudo sh

The logs I get are below, including the start of the management center logs when I access it in the browser. So it all worked for me. The difference I see in the logs is that your containers are named differently. The other differences are down to you giving logs from a second run whereas this is the first run.

Do you have any ideas if what you did was different?



Hi Roger,

thanks for your help after starting from scratch I tested right away and it worked. So digged a little deeper and found the problem was ufw-docker. After removing it from the after.rules and a reboot it just worked. I just don’t know why yet, it’s the first time I had problems with ufw-docker.

1 Like