Docker install failed ,Exit(0) inmediately

docker run -itd --name=streamsheets -p 8888:8081
-v /streamsheets:/streamsheets cedalo

and the container state was exit(0), I tried so many ways but can not make it up .


Hi quanwenbo,

Have you already tried the two steps from the documentation and they did not work for you?

Step 1: Get the installer on to you local directory: docker run -v ~/streamsheets:/streamsheets cedalo/streamsheets-installer:1.6-milestone-linux

Step 2: Run the file. sh (sometimes sudo is needed)

In your docker run statement you are trying to run the installer as the Streamsheets software, which are two different images. :slight_smile:

thank you ,I made it yesterday afternoon ,the first installer container did’t need to be “up” state,just docker run and cd ~/streamsheets ,and sh , and will be done. Before I understood this I always try to make the installer container run up . but in fact it do not need.

But there is a new problem , when I deleted some thing and tried to go to Administration I got this .
It will always turning a circle ,and I can do nothing but keep watching.

And I am a chinese guy ,Could I suggest that The Language add a choice of Chinese?
I think a lot of people here will like this OPEN software.
If some translation work need help ,I can try to give some.

Glad we got the first problem sorted out :wink:

About the second:
Do you know what you deleted?
Did you delete something inside the software? Or somewhere else?

I totally understand, that adding further languages would help many people. But at this point in time, we don’t have the manpower to support it. Thank you for your offer!!
I hope English is fine for now with you. If you have further trouble understanding, I hope we can figure it out over the forum :slight_smile:

I can’t remenber so clearly, seems like some Producers, Connectors ,and Consumers.

If I meet again, you will know it immediately. TKS.

1 Like