Install on CentOS 7

I am trying to get StreamSheets up and running on a Centos 7 instance hosted on AWS. The OS version is CentOS Linux release 7.6.1810 (Core).

I followed the instructions from here to install Docker:

At the end of the docker installation the hello-world image runs properly

I then followed the instructions from here to install StreamSheets:

When I initially tried to run sudo ./ it indicated that docker-compose was not present. I then installed this using “sudo yum install docker-compose” and tried to run the command again.

This is what I get:
“ERROR: Version in “././docker-compose.yml” is unsupported. You might be seeing this error because you’re using the wrong Compose file version. Either specify a supported version (e.g “2.2” or “3.3”) and place your service definitions under the services key, or omit the version key and place your service definitions at the root of the file to use version 1.
For more on the Compose file format versions, see Compose file | Docker Documentation

Here are the contents of the docker-compose.yml file:
version: “3.6”

  • streamsheets:*
  • image: cedalo/streamsheets:2-milestone*
  • ports:*
  •  - 8081:8081 # Frontend and APIs*
  • expose:*
  •  - 8081*
  • volumes:*
  •  - streamsheets-data:/var/lib/mongodb*
  •  - ./streamsheets/init.json:/streamsheets/packages/gateway/config/init.json*
  •  - ./streamsheets/data:/streamsheets/data*
  • environment:*
  •  FILE_STREAM_DEFAULT_ROOT: "/streamsheets/data/filestream"*
  • networks:*
  •  - cedalo-platform*
  • logging:*

  • driver: “none”*


  • streamsheets-data:*
  • external: true*
  • cedalo-platform:*
  • name: cedalo-platform*
  • driver: bridge*

Can anyone point me in the right direction to resolve this.

Hi glashinc,

You can check your docker-compose version via: docker-compose -v

There could have been an error while installing docker-compose.
As a first step, I recommend uninstalling and reinstalling.

Uninstall and reinstall worked. Thanks

perfect, glad to hear that :slight_smile: